v61. Performance has degraded once again.

Why? Why can we not just get improvements?

v59.1 was the last time the game actually ran fine on my phone.

v59.2 introduced incredible stuttering and noticeably worse framerate on the 60fps setting so I locked to 30fps.

v60 removed some of the stuttering, but did not improve the worsened framerate.

And now with v61. The framerate has DROPPED once again, and at Low settings on 30 FPS, my phone in a cool environment with a fan blowing on it holds 25-28 FPS. Really?

Phone Model: Pixel 7 (Tensor G2 Chip) [Released October 2022]

I feel like my phone really should not be struggling this hard to even hit 30FPS on minimum graphics, given it was doing just fine barely a month ago.

Tagged:
17
17 votes

Bug: Reported to the team · Last Updated

Comments

  • Stampeder
    Stampeder Posts: 536

    Hmm so far it's still running fine on my phone, but I'm on Low setting + 60fps during hunts, and have my phone's game mode enabled for it.

    Have you tried clearing the app's data and re-login and re-download all assets? I know this is not the best option, but if it helps, it's better than having to deal with the stutters :)

  • Goldtistic
    Goldtistic Posts: 24

    Cleared cache, fully uninstalled, logged back in and made sure all assets were downloaded. Low Settings + 60 FPS had me jumping from 22 to 35 fps, which was some unplayable framerate bouncing. Set it to Low Settings + 30 FPS, hovering around 28-30 fps, and regularly dipping to 20 FPS when a lot of VFX occurs, like my arrows critting or a perfect dodge.

    During v59.1, my phone was able to handle Medium Settings + 60 FPS and pull 40-45 FPS.

    I understand the Pixel 7 isn't a very expensive or necessarily powerful phone, but everyone I know with a Pixel including the users with the Pro version have had a degrading experience with each update. I'm gonna stop going outside to play until this improves, as this mediocre performance is happening in a cool room with a fan on. Going out to hunt in the sun would surely be a miserable playing experience.

  • Stampeder
    Stampeder Posts: 536

    Wow. That doesn't make sense; your Pixel 7 has better hardware than mine. I'm using Huawei Mate 20, and the only time my phone struggles at Low Setting is when I stood still activating my Dragon Piercer while Paolumu throws a sandstorm in my face, in which my whole screen just go down to maybe single-digit FPS. Other than that, perfect dodging and Bow Rapid 4 double shots at point-blank are fine. Your phone ought to perform better than my phone.

  • Same with me, I'm using Xiaomi 12t only get 30-35 fps, meanwhile if I'm using my 5 years Poco f1 phone ,I can get 60fps in every battle that doesn't make sense

  • Powerghost
    Powerghost Posts: 58
    edited September 2023

    I was able to play at medium graphics without any performance problems at all. But now (after the latest update) i sometimes even get lag at low graphics. Anyone else having the problem too?

    I play on Android.

    Please Niantic, do some performance optimization (especially for battles against big Monsters) .

  • Thanks for posting this!

    I've been having the same FPS drop / stuttering since v.60 (global release) and still having it in the current version 61. Surely makes hunting unbearable most of the times with lack of timing for counters and dodges due to huge lag spikes!

    Running MHNOW on a Xiaomi Mi 9T Pro (Snapdragon 855 / 6GB RAM) just for the record.

    UP!

  • Niantic support 11
    Niantic support 11 Posts: 150 mod
    edited September 2023

    Hello @Powerghost. Can you please help us with some information such as your device model/details including your OS version and also from where or how you downloaded the app so that we can look into it further?

  • Powerghost
    Powerghost Posts: 58
    edited September 2023

    Android 11, Samsung Galaxy A70, i downloaded the game and update from Google play Store

    @Niantic support 11

  • ShuanWuLin
    ShuanWuLin Posts: 3

    Thanks for posting this!

    I've been having the same FPS drop / stuttering since too,in the current version 61.

    For the record too.

    I'm running MHNOW on ROG Phone 6D (Octa-Core Max 3.2GHz / MediaTek Dimensity 9000+ / 16GB RAM / Android 13).

    UP!

  • Powerghost
    Powerghost Posts: 58

    Performance is much worse for me too.

    Android 11, Samsung Galaxy A70

    Was able to play at medium graphics without any performance problems at all but now i can't even play at low graphics without having stuttering and slowdowns in most battles against big monsters.

  • Drivensane
    Drivensane Posts: 5

    Same here on a54 with low settings and even game booster reducing quality by a addition 50%

  • Drivensane
    Drivensane Posts: 5

    Same here on a54 with low settings and even game booster reducing quality by a addition 50%

  • Niantic Support 12
    Niantic Support 12 Posts: 169 mod
    edited September 2023

    Hello, @Powerghost and @Drivensane

    It's possible that the device you're currently using may not be able to play Monster Hunter Now due to CPU limitations. If you're still experiencing issues with the game, we suggest attempting to play it on an alternative device.

    To learn more about supported devices, click this link: https://niantic.helpshift.com/hc/en/39-monster-hunter-now/faq/3939-supported-devices/

    Post edited by Niantic Support 12 on
  • Powerghost
    Powerghost Posts: 58

    I checked the CPU and mine is weaker, but the game was running without problems at medium graphics before the update. Now i play at low graphics and still get slowdowns and lag. Such a big change in performance should not happen because of an update.

    I would understand it if i get performance problems in a fight with a lot going on, for example if Teostra was in the game and would cause a lot of explosions at once.

    And i see a lot of people complaining about performance being worse since version 61, so i wouldn't be surprised if a bunch of People stop(ped) playing because of this.

  • Rurozan
    Rurozan Posts: 16

    +1

    EVERY monster attack causes a 3+ second hang / lag in the action, but the timer keeps going. As I progress through the game and monsters attack more often, I am hitting a wall simply because the match times out.

    I experienced similar with PokeGo, and it seemed to be AT&T network, while people on Verizon had no issues.

    My phone should also be plenty capable, it ran Go.

    Either need to fix the optimization or just get rid of the timer. It's redundant anyway, people can lose by health.

  • Rurozan
    Rurozan Posts: 16

    Unplayable as I progress, each monster attack causes lag / an entire slowdown of action but timer keeps ticking.

    There is nothing more I can do on my end, phone is optimized, lowest settings, nothing else running.

  • Drivensane
    Drivensane Posts: 5

    That doesn't make sense as there's phones worse than mine getting solid 60 fps and my gf who's cpu is only about 10-15% better than mine is also getting 60 fps. Yet I'm stuck at 20ish if I'm lucky.